Internal Server Error on Godaddy, WordPress

This blog is running on Godaddy.com hosting Linux server and I have getting the error ‘Internal Server Error – The server encountered an internal error or misconfiguration and was unable to complete your request.’

After doing some research, I have found out that this is caused by Wp-Cache Plugin which seems to have a compatibility issue with Godaddy hosting and WordPress blogging platform. Disabling the plugin got rid of the 500 Internal server error messages.

Wp-Cache plugin adds a lot of speed to the site by caching the pages. There is a Wp-Cache plugin with Godaddy fix version which can be downloaded at Givveronline or use the WP Super Chache plugin which has the Godaddy 500 Internal server error fix.

Updated the WordPress from 2.5.1 to 2.6

Use the below easy steps to update WordPress blog

1. Backup the blog.

2. Download the Latest Version of WordPress and unzip.

3. From the new version, delete the two folders wp-config and wp-content folder.

4. Stop all the plugins to be on safe side.

5. Using a FTP client, replace all the files on remote server with new version.

6. Update the database ‘http://www.yourblog.com/wp-admin/upgrade.php

7. If you have deactivated the plugin’s, re activate them again and check if all are active.


You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.

Leave a Reply